Форум Flasher.ru

Форум Flasher.ru (http://www.flasher.ru/forum/index.php)
-   Серверные технологии и Flash (http://www.flasher.ru/forum/forumdisplay.php?f=62)
-   -   Проблема с Flash Media Server 2 (http://www.flasher.ru/forum/showthread.php?t=87906)

jaydee 14.11.2006 01:41

Проблема с Flash Media Server 2
 
Нужна помощь! Установил FMS2 на windows xp (поставил версию 2.0.3). Проблема в следующем, swf-ки не коннектятся к серверу, абсолютно все, кроме админки. Причем не коннектятся даже sample applications от macromedia. В логах сервер пишет следующее:
Tue 03:40:11 AM: Asynchronous I/O operation failed (Failed to attach to completion port: Параметр задан неверно. 87).
Кто знает в чем проблема? Никак не могу понять....

FourSide 14.11.2006 11:35

Код бы помог разобраться... а также описание настроек - порты, хосты, каталоги....

И еще желательно бы знать, какой код ошибки выдаёт сервер при попытке подключения.

jaydee 14.11.2006 12:52

порты стандартные: 1935 для приложений, 1111 для админки.
Причем что самое интересное, сервер фиксирует подключения и мнгновенные отключения от сервера (в колонки Connects и Disconnects добавляет по единичке, а в колонка Connected так и остается со значением 0). В логах пишет только это.
Вот пример лога ядра:

Цитата:

#Version: 1.0

#Start-Date: 2006-11-14 03:26:04

#Software: Macromedia Flash Media Server 2.0.3 r68

#Date: 2006-11-14

#Fields: date time x-pid x-status x-ctx x-comment

2006-11-14 03:26:04 660 (i)2581237 Starting admin app on core (660). -

2006-11-14 03:26:04 660 (i)2581231 Core (660) connected to admin. -

2006-11-14 03:26:04 660 (i)2581234 Core (660) connection to admin accepted. -

2006-11-14 03:26:30 660 (w)2631008 Asynchronous I/O operation failed (Failed to attach to completion port: Параметр задан неверно. 87). -

2006-11-14 03:40:11 660 (w)2631008 Asynchronous I/O operation failed (Failed to attach to completion port: Параметр задан неверно. 87). -

2006-11-14 03:43:06 660 (i)2581247 Core (660) disconnected from edge. -

2006-11-14 03:43:06 660 (i)2581233 Core (660) disconnecting from admin. -

2006-11-14 03:43:06 3356 (i)2581247 Core (3356) disconnected from edge. -

#End-Date: 2006-11-14 03:53:06
Подключатся соотвественно пытается к localhost. Intstance приложения на сервере запущен, в чем проблема? Админка ведь коннектится.
Сделал простой тестер:
Код:

main_nc = new NetConnection();
main_nc.connect("rtmp://localhost:1111","login","pass");
main_nc.onStatus = function(info) {
        if (info.code == "NetConnection.Connect.Success") {
                trace("Connect successful.");
        } else if (info.code == "NetConnection.Connect.Failed") {
                trace("Unable to connect.");
        }
};

- подключается к админке без проблем: трейсит "Connect successul.".
Ну а в случае с приложениями - "Unable to connect."

FourSide 14.11.2006 17:47

Попробуйте создать хоть один рум (комнату), например (фантазия моя сегодня скудна) - test.
Коннект будет выглядеть тогда:
Код:

...
main_nc.connect("rtmp://localhost/test");
...

"Комнаты" - это подкаталог в каталоге applications. Т.е. создайте там подкаталог и попробуйте соединиться снова по указанной строчке.

vooparker 14.11.2006 18:17

а разве на XP FMS можно юзать??? System requirements на adobe говорят об обратном:

Supported operating systems:
Windows 2000 Server
Windows 2003 Server, Standard Edition

про XP ни слова.
Или все таки такое возможно?

iNils 14.11.2006 18:24

jaydee, я вам уже написал в одной теме, но повторюсь, для оформления своего кода, надо использовать теги [code][/code]. Больше предупреждений не будет.

FourSide 14.11.2006 19:09

Цитата:

Сообщение от vooparker
а разве на XP FMS можно юзать??? System requirements на adobe говорят об обратном:

Supported operating systems:
Windows 2000 Server
Windows 2003 Server, Standard Edition

про XP ни слова.
Или все таки такое возможно?

У меня дома Windows XP HE SP2.
На работе Windows XP Professional SP2.


FMS работает без нареканий вообще.

vooparker 14.11.2006 19:38

2FourSide: спасибо

jaydee 14.11.2006 21:02

Сначала to vooparker: Нужно лучше читать документацию, чтобы не задавать таких вопросов!
Цитата:

Flash Media Server can be deployed on the following systems:
¦ Microsoft Windows 2000 Server or Windows 2003 Server - Standard Edition running on
a Pentium III 1-GHz processor or faster (Dual Pentium 4 or faster recommended).
Windows XP is acceptable for developing and testing applications.
¦ Linux Red Hat Enterprise Version 3.0 and Linux Red Hat Enterprise Version 4.0 running
on a Pentium III 1-GHz processor or faster (Dual Pentium 4 or faster recommended).
Your deployment system for Flash Media Server applications also requires the following:
¦ Minimum of 512 MB of available RAM.
¦ 50 MB of available disk space.
¦ CD-ROM drive for installation.
to iNils: извиняюсь, давно тут не был, совсем забыл про это! как видишь, исправляюсь.

to FourSide: ну что же совсем за ламера то меня считать. Делал я то что ты мне предложил, и уже не раз! Не помогает. Зато почитай вот, что я нашел в документации только что. Это как раз мой случай:
Цитата:

Software designed to make network connections mimic modems or DSL lines in order
to save bandwidth, such as NetLimiter, can intercept system calls and break Flash
Media Server socket actions. The error message “Failed to Attach Completion Port, the
parameter is incorrect” appears. Before installing Flash Media Server, remove this type
of software. Also, do not install this type of software after Flash Media Server is installed.
You may use this type of software on the client, but do not use it on the same machine as
the server.
Как раз мой случай! Смотри а! Код ошибки точно такой же. Попробую вообще вырубить брэндмауэр. Но все равно, спасибо всем кто ответил.

FourSide 14.11.2006 21:24

Сообщи о результатах, плз, очень интересно :)

jaydee 14.11.2006 21:31

Брэндмауэр мать его, не получается все равно. Вырубил его, добавил прогу и порты во все исключения, а все равно тоже самое. Кто знает как его вообще удалить? Чтобы он не блокировал ничего? Хелп
П.С.: хорошо что хоть выяснили, в чем проблема.

jaydee 14.11.2006 22:26

2 FourSide: у тебя говоришь на работе все ок, у меня стоит WinXP Sp2, как ты сделал чтобы у тебя работало? или у тебя с самого начала еще проблем не было?

FourSide 15.11.2006 12:08

Не было проблем. Вообще. Установил и всё заработало (ну может быть после перезагрузки - уже не помню).

У меня были подобные ошибки отсоединения в дувух случаях:
1. Когда в файле fms.ini не был прописан путь к applications
2. Когда коннектился клиентом без указания "комнаты".

jaydee 15.11.2006 14:07

Эх, все это я уже проверял на сто раз. Все правильно настроено.
Почему не коннектится? Брэндмауэр или что-то другое? Вопрос остается открытым....

jaydee 16.11.2006 12:00

кто-нибудь помогите вырубить брэндмауэр!

tirpir 08.12.2006 14:03

такая же фигня :(
я в этом вообще полный ноль!!
на одной машине стоит FMS v2 и Flash8
создаю папочку в applications - "mycomapp"

во флеше:
Код:

client_nc = new NetConnection();
client_nc.connect("rtmp:/mycomapp");
client_nc.onStatus = function(info) {
trace("Level: " + info.level + " Code: " + info.code);
}

флеш пишет:
Код:

Level: error Code: NetConnection.Connect.Failed
А сервак:
Код:

Fri 12:59:47 PM: Asynchronous I/O operation failed (Failed to attach to completion port: The parameter is incorrect. 87).
Winxp sp2

________________________________________________-
А если в *rtmp я указываю адресс (локальный или внешний) соседней машины с win2000, на которой стоит этот же сервак то
Код:

Level: status Code: NetConnection.Connect.Success
есть ли кого соображения?

Yuorik 13.12.2006 14:15

У меня таже проблема... :( все уже вырубил. И всеравно не работает :(
Интересно было бы узнать результат.

Аркади 14.12.2006 12:45

main_nc.connect("rtmp://localhost:1111","login","pass"); без указания имени приложения работать не будет, да и вообще фигня какая-то написана. в доке же сказано как к локальному конектица main_nc.connect("rtmp:/app");
соотв в FMS должна быть папка app , а в ней файл main.asc

Yuorik 17.12.2006 13:24

Цитата:

Сообщение от Аркади
main_nc.connect("rtmp://localhost:1111","login","pass"); без указания имени приложения работать не будет, да и вообще фигня какая-то написана. в доке же сказано как к локальному конектица main_nc.connect("rtmp:/app");
соотв в FMS должна быть папка app , а в ней файл main.asc

Пробовал я это.. Не помогает.

Аркади 18.12.2006 16:16

а что флэш говорит ?
выкладывай исходник, посмотрим, потом будет ясно где ошибка

Yuorik 18.12.2006 22:21

Ребята !!! на работе работает а дома нет (причем на работе ХP+SP2 и дома тоже самое)... тут дело не в исходниках. 4-тый год с флешем работаю. Тут дело в настройках винды я так понимаю (возможно настройка сервисов). Сегодня попробую конфигнуть винду дома также как и на работе она у меня настроена.

tirpir 19.12.2006 15:56

Все отрубил!
в файле hosts тоже все лишнии записи убил!
софт типа интернет security тоже убил.
неработает и все тут!

INK• 28.12.2006 04:31

Антивирус Касперского установлен?
если да то эта софтина ставит враперы тцп\айпи

ну и так же другие подобные программы могут ставить свои враперы tcp\ip

у меня было такое. непомню правда что писало.

adelante 17.02.2007 21:32

хана, тоже самое....

If you get the error "Asynchronous I/O operation failed (Failed to attach to completion port: The parameter is incorrect. 87)." Get ready to reformat your entire machine. This software is way to picky and I would suggest having a computer loading with nothing but Flash Media Server 2 until Adobe can get a list together of incompatiable software with this server. I've tried for months and I still can't figure out which software is causing this thing to stop working. Very very annoying.

http://livedocs.adobe.com/cfusion/rs...html&full=true

Самое интерестное, что если установить FCS 1.5 то все куль, а вот с FMS не хочет...
П.С. у меня XPProf+SP1 (установлен только антивирус нод32)

etc 17.02.2007 21:45

adelante получает плюс за флуд.

adelante 17.02.2007 21:51

ок, постить не буду.

adelante 18.02.2007 10:40

Решение было найдено после 7 часов упорного поиска инфы в нете.
Удаляем ВСЕ антивирусы, фаерволы и т.д. и т.п. Ключевое слово УДАЛЯЕМ.

FourSide 18.02.2007 16:54

Наверное, можно было отключить в "Сервисы" эти программы. Обычно помимо основной программы-антивируса еще устанавливаются независимые сервисы (при выключении программы сервисы не отключаются).

Аркади 19.02.2007 09:49

недавно возникла та же самая пробелма после установки антивируса Nod32

после удаления все заработало ок

tirpir 21.02.2007 12:24

У меня тоже нод стоит!
Щас поробую удалить и поновой поставить FMS

MyXus 06.03.2007 16:09

Ребята. Это надо кудато прикрепить!
Я тоже потратил полдня прежде чем нашел этот топик.
Удалять NOD32 !!!!!

fellis 16.11.2007 13:12

доброе время суток!
У меня win xp professional sp2 english(не лицензионная). после удаления nod32 и kerio personal firewall, приложения Flash media server так и не стали запускаться. На работе стоит win xp professional sp2 russian(лицензионная), с самого начала после инсталяции windows были выключены брэндмауэр и не ставились никакие антивирусы. FMS работает корректно.

Может найдуться какие-то соображения, почему на домашнем комьютере FMS так и не может запуститься? следует ли переставить ОС? или удалить все ключи на фаерволл и антивирус в реестре windows?

Есть ли какая-то другая версия FMS, которая может быть установлена более гладко??

jaydee 18.11.2007 00:44

Ничего не следует переставлять. Еще на форумах макромедии писали, что антвирусное программное обеспечение (не всё, но НоД32 точно) блокируют FMS, как собственно и фаерволы. У меня дома тоже ничего не коннектится так: rtmp:/fmsApp . Выход - юзать HTTP туннелинг. То есть, чтобы дома свободно заниматся разработкой и тестить приложения, подкючайся к приложению из флэшки так: rtmpt://localhost:1935/fmsApp . t-значит туннелинг через порт 80. bandwidth падает, но для домашнего тестинга пойдет.

Роман Вадимович 21.11.2007 15:41

Cупер, спасибо. Это работает.
Подскажите. Если я проинсталлил FlashServer на одном компе с WindowsXP. То я могу подключиться клиентским приложением на другом компе в этой же локальной сети.
Читал про:
Код:

rtmp://server/Application
Ну а что писать в server? IP-адрес? Пробовал - не получается :(

Роман Вадимович 22.11.2007 14:02

В общем, если кому-то интересно получилось так:
Код:

rtmpt://<ip-адрес_сервера>:1935/<название программы>
Жалко, что bandwidth падает :(

terion27 03.04.2008 15:49

Возможно ли брать поток с юникаста и потом его транслировать, если да, то как это реализовать... перерыл уже вмого доков, но так и не нашел вразумительного ответа...


Часовой пояс GMT +4, время: 03:33.

Copyright © 1999-2008 Flasher.ru. All rights reserved.
Работает на vBulletin®. Copyright ©2000 - 2026, Jelsoft Enterprises Ltd. Перевод: zCarot
Администрация сайта не несёт ответственности за любую предоставленную посетителями информацию. Подробнее см. Правила.